PHP7 – MariaDB

Étiqueté : ,

Ce sujet contient 5 réponses, 2 participants et a été mis à jour pour la dernière fois par Jérôme, le il y a 3 années et 10 mois.

Vous lisez 5 fils de discussion
  • Auteur
    Messages
    • #1357


      PYF
      Invité

      Bonjour
      Je suis en train de tenter une install sur une DEBIAN tout fraichement installée.
      MYSQL a été remplacé par MariaDB (ce qui est normalement transparent) et la version de PHP est maintenant en standard la 7.
      Est ce que PlanningBiblio est compatible ?
      Jai tenté une install mais je n’arrive pas à passer l’étape de la connexion à la base de données.
      J’ai fait une connexion manuelle (mysql -u utilisateur -p) et je me connecte pourtant bien en ligne de commande … D’où ma question !
      Merci de votre retour
      PYF

    • #1359


      Jérôme
      Maître des clés

      Bonjour,

      Je viens de faire les essais avec Debian 9, PHP7 et MariaDB.

      ça fonctionne correctement mais il faut au préalable ajouter un mot de passe au compte root et lui attribuer tous les privilèges avec GRANT OPTION.

      D’ailleurs, si vous essayer de vous connecter à phpmyadmin avec le compte root, l’accès vous sera également refusé.

      Voici ce que j’ai fait (attention, à reproduire avec prudence, à vos risques et périls. Ceci concerne l’administration du serveur MariaDB et non Planning Biblio) :
      – Suppression du compte root existant
      – Création d’un nouveau compte root avec un mot de passe
      – Attribution des privilèges

      mysql -u root -p
      >DROP USER 'root'@'localhost';
      >CREATE USER 'root'@'localhost' IDENTIFIED BY 'my_password';
      >GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' IDENTIFIED BY 'my_password' WITH GRANT OPTION;
      >FLUSH PRIVILEGES;
      
    • #1360


      PYF
      Invité

      Bonjour
      Merci pour cette réponse rapide et précise.
      Effectivement, cela règle le problème sur cette étape.
      J’en profite pour préciser que comme recommandé, j’avais exécuté le script mysql_secure_installation avant et je pense que c’est ça qui a du faire bloquer l’install.
      Votre manip restaure les droits et permet la création d’un utilisateur ayant tous les droits sur la base de données nouvellement créée. Sur le principe, c’est comme ça que nous configurons nos serveurs habituellement (une utilisateur isolé pour chaque base de données), ca cloisonne, c’est « safe », c’est nickel.
      Bon, je crains toutefois d’avoir un nouveau problème car quand je suis sur le formulaire pour créer l’admin, ca plante systématiquement en me disant qu’il y a des erreurs.
      Je suis allé voir dans la base et rien ne se créée.
      Pourtant l’utilisateur dédié est bien présent avec les droits sur la base de données de PlanningBiblio.
      Je vais tout réinstaller et ne pas utiliser le script de sécurisation MySQL. On verra ce que ca donne …

    • #1361


      PYF
      Invité

      Ok pour moi également
      Il ne faut pas installer le script de sécurisation mysql et appliquer la méthode que vous évoquez au niveau de la conf de MYSQL (supprimer le compte root et le recréer) et cela fonctionne bien.
      La conf chez nous est DEBIAN 9 / MARIADB / PHP7, le tout virtualisé via PROXMOX.
      Pour info, nous avons tout crypté via un certificat LETSENCRYPT (pour avoir du https) et cela fonctionne sans soucis pour le moment.
      Pour les emails, nous avons installé POSTFIX en plus.
      Merci pour tout ce travail.

    • #1363


      Jérôme
      Maître des clés

      La manip sur les privilèges root m’a permise d’aller jusqu’au bout de l’installation.

      Mais bon, si le formulaire permettant de créer le compte admin échoue, vous pouvez normalement vous connecter avec le compte admin, mot de passe password, puis changer ensuite le mot de passe et les autres infos associées au compte.
      (Le compte admin est créé dès le début de l’installation, le formulaire permet finalement de le personnaliser et de changer son mot de passe).

      Mais il vaut mieux savoir d’où vient ce problème car il pourra peut être gêner par la suite.

    • #1364


      Jérôme
      Maître des clés

      Je n’avais pas vu votre 2ème réponse.

      Tout fonctionne donc, très bien (-;

Vous lisez 5 fils de discussion

Répondre à : PHP7 – MariaDB

Vos informations :