Pas de connexion SMTP

Étiqueté : 

Ce sujet contient 8 réponses, 2 participants et a été mis à jour pour la dernière fois par Imad, le il y a 4 années et 5 mois.

Vous lisez 8 fils de discussion
  • Auteur
    Messages
    • #1267


      Imad
      Invité

      Bonjour,

      Je suis en train d’installer planning biblio sur un serveur Debian
      La solution s’installe très bien
      En revanche lors du test d’envoi de mail, dans la configuration de la messagerie, une erreur survient avec le message suivant:
      Pas de connexion SMTP
      Est-il nécessaire d’installer un postfix sur le serveur, sachant que nous utilisons déjà un serveur de messagerie interne ?

      Merci à vous !

    • #1268


      Jérôme
      Maître des clés

      Bonjour,

      Vous n’avez pas besoin de postfix si vous utilisez un serveur SMTP existant.

      Dans ce cas, le paramètre Mail-IsMail-IsSMTP doit être sur IsSMTP et vous devez remplir les paramètres SMTP.

      Il se peut que la messagerie fonctionne malgré l’erreur du test (le test en lui-même ne fonctionne pas très bien).
      Pour vérifier ceci, créer un agent avec une adresse e-mail valide et voyez si vous recevez le mot de passe (vous pouvez également cliquer sur le lien « changer le mot de passe » d’une fiche existante).

      Cordialement,
      Jérôme

    • #1282


      Imad
      Invité

      Bonsoir et merci de m’avoir répondu

      Je crains d’être bloqué, car après avoir renseigné le formulaire de configuration de messagerie, j’obtiens toujours le message d’erreur SMTP, lors du renouvellement de mot de passe d’un agent

      Dois-je paramétrer le fichier class.phpmailer.php à la main ? Si oui, y a t-il un autre fichier à paramétrer ?

      Bien cordialement,

      Imad

    • #1283


      Jérôme
      Maître des clés

      Bonjour,

      Quel est le message exact ?
      Pas de connexion SMTP ne fait pas partie des messages d’erreur.

      Il n’y a pas de fichier à modifier, tous les paramètres nécessaires peuvent être saisis dans le menu administration / configuration / messagerie.

      Etes-vous sûr de vos paramètres ?

      Vous pouvez faire les tests suivants pour voir s’il n’y a pas de problèmes réseaux entre le serveur Planning et le serveur SMTP :
      ping adresse_du_serveur
      telnet adresse_du_serveur port

      exemples:
      ping smtp.mondomaine.com
      telnet smtp.mondomaine.com 25

      Si l’un de ces tests ne fonctionnent pas, soit les paramètres sont incorrects (exemple le port), soit il y a un problème réseau (exemples : blocage du pare-feu, connexion refusée par le serveur SMTP, problème de résolution de nom (dans ce cas, essayez avec l’adresse IP)).

      Vous devez également faire attention aux paramètres de sécurité (SSL, TLS ou rien) et d’authentification si le serveur la demande (login, password)

      J’espère que ceci vous aidera.
      Tenez-nous informés.

      Cordialement,
      Jérôme

    • #1284


      Imad
      Invité

      Bonjour,

      Merci pour les pistes de recherches.
      Le message apparaissant dans l’infobulle informe qu’il n’y pas de connexion SMTP.

      Après avoir fait quelques tests, il semblerait qu’il n’y ait pas de résolution DNS

      Je vous tiens informé et cela pourra peut-être utile aux autres

    • #1285


      Imad
      Invité

      Il y avait effectivement un problème de résolution DNS
      Nous y avons remédié, mais cela n’a pas solutionné le problème
      Le message dans l’infobulle indique « Echec de la connexion SMTP »

      Pour paramétrer la messagerie de planningbiblio, nous avons utilisé le même paramétrage qu’utilisé dans d’autres application que nous utilisons comme GLPI

      Auriez vous d’autres pistes ?

      En vous remerciant,

      Cordialement,

    • #1286


      Imad
      Invité

      Re-bonjour

      Nous sommes peut-être sur une piste

      Cela viendrait d’un problème de négociation SSL

      Pouvez vous nous indiquer quel journal consulter pour avoir les transaction SMTP ?

      En vous remerciant,

      Cordialement,

      Imad

    • #1287


      Jérôme
      Maître des clés

      Bonjour,

      Je ne pense pas qu’il y ait d’autres journaux que les logs apache.

      Sinon, renseignez vous en faisant des recherches sur PHPMailer.
      J’en ai fait quelques unes et je vois déjà 2 choses :
      – le module PHP OpenSSL doit être activé
      – Vous pouvez utiliser la méthode PHPMailer « SMTPDebug » pour avoir plus d’informations sur les erreurs SMTP : la modification du code est nécessaire, au moins pour les tests. Je ne peux vous en dire plus, je n’ai jamais utilisé cette méthode et n’ai jamais eu d’erreur de négociation SSL.

      Je pense que le certificat du serveur SMTP doit être signé par une AC reconnue.
      Il se peut aussi que la version SSL du serveur SMTP ne soit plus prix en charge par les nouvelles versions de PHPMailer

      Cordialement,
      Jérôme

    • #1305


      Imad
      Invité

      Bonjour,

      Nous n’avons pas réussi à résoudre le problème même après avoir vu les différent logs et fouillé du coté de PHPMailer et en désactivant SSLv3.
      Cependant, nous l’avons contourné en utilisant une autre adresse de serveur mail interne

      Nous vous remercions pour l’aide apportée

      Cordialement,

      Imad

Vous lisez 8 fils de discussion

Répondre à : Pas de connexion SMTP

Vos informations :




Annuler