Installation : erreur update user

Mots-clés : 

Ce sujet a 1 réponse, 2 participants et a été mis à jour par  Jérôme, il y a 3 semaines et 3 jours.

  • Auteur
    Messages
  • #2956


    Laurence

    Bonjour,

    J’ai installé planningbiblio 20.04 sur un serveur ubuntu 20.04.
    j’ai installé Apache 2, php 7.4.3, mysql 8.0.21, git et composer.. en suivant la procédure. Je suis bien propriétaire du dossier et sous dossier.
    Quand je lance le fichier intall.sh, j’ai deux messages d’erreurs et je n’arrive pas à savoir d’où ça vient :

    ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘IDENTIFIED BY ‘planning » at line 1

    ERROR 1142 (42000) at line 1: UPDATE command denied to user ‘planningbiblio’@’localhost’ for table ‘personnel’

    Du coup je pense que c’est pour ça que je n’ai pas la création du dossier vendor et donc bloqué dans l’installation.
    Merci de votre aide par avance
    Cordialement
    Laurence
    Université Paris Sud

  • #2958


    Jérôme
    Admin bbPress

    Bonjour,

    La première erreur est probablement liée à la version de MySQL utilisée.
    Nous préconisons l’utilisation de MariaDB 10.

    La seconde erreur est liée à la première. L’utilisateur n’ayant pas été créé, les droits d’accès sont refusés.

    En cas d’échec de création de la base de données, le processus d’installation s’arrête. Le dossier vendor et le fichier de configuration ne sont donc pas créés.

    Essayez avec MariaDB 10 à la place de Mysql 8 (les packages MariaDB sont disponibles sous Ubuntu).

    Cordialement,
    Jérôme

Répondre à : Installation : erreur update user

Vos informations: