Access denied for user ‘root’@’localhost’

Étiqueté : 

Ce sujet contient 2 réponses, 2 participants et a été mis à jour pour la dernière fois par foucaud, le il y a 2 semaines et 2 jours.

Vous lisez 2 fils de discussion
  • Auteur
    Messages
    • #3047


      Fouocaud
      Invité

      Bonjour.

      Après avoir lancé install.sh et renseigné les données, je suis confronté à une série d’erreurs ERROR 1698 (28000): Access denied for user ‘root’@’localhost’

      Faut-il modifier les privilèges root, comme indiqué par certains forums ?
      https://askubuntu.com/questions/1029177/error-1698-28000-access-denied-for-user-rootlocalhost-at-ubuntu-18-04
      Je préfère avoir votre avis avant de tenter quelque chose qui perturberait le fonctionnement. Voir même, me conseiller sur les instructions Mysql à lancer (il y-a plusieurs solutions différentes suggérées sur les forums).

      Plus de détails config et comportement ci-dessous.

      Autre question : Pas trouvé le dossier « var » dont il faut modifier les droits d’accès. Il est censé être dans planningbiblio ou dans planningbiblio/public ?

      Merci de votre aide … et merci pour ce programme très utile 😉

      Config :
      Debian 10
      php 10,4
      10.3.27-MariaDB

      la commande mysql
      SELECT User, Host, plugin FROM mysql.user;
      indique
      User | Host | plugin |
      +———-+———–+————-+
      | root | localhost | unix_socket |
      | planning | localhost | |

      Détail de l’exécution :
      ./install.sh  
      You are about to install Planning Biblio
      You will be asking for information to create the database.
      A database and a user will be created with given information. WARNING: if the database and the user already exist, they will be overwritten
      We strongly recommend that you back up your databases before starting this installation
      Do you want to proceed ? [yes/no]
      yes
      DB Host [localhost] :
      DB Port [3306] :
      DB Admin User [root] :
      DB Admin Pass : …
      *****
      DB User [planningbiblio] (will be overwritten if exists) :
      DB Pass […] (will be overwritten if exists) :
      **********
      DB Name [planningbiblio] (will be overwritten if exists) :
      Planning Biblio admin’s lastname [admin] :
      Planning Biblio admin’s firstname [admin] :
      Planning Biblio admin’s e-mail address [admin@example.com] :
      planning-biblio@univ-pau.fr
      Planning Biblio admin’s password [….] :
      Update composer dependencies [no] :
      ERROR 1698 (28000): Access denied for user ‘root’@’localhost’
      ERROR 1698 (28000): Access denied for user ‘root’@’localhost’
      : Access denied for user ‘root’@’localhost’
      ERROR 1698 (28000): Access denied for user ‘root’@’localhost’
      ERROR 1698 (28000): Access denied for user ‘root’@’localhost’
      ERROR 1698 (28000): Access denied for user ‘root’@’localhost’
      ERROR 1698 (28000): Access denied for user ‘root’@’localhost’
      ERROR 1045 (28000): Access denied for user ‘planningbiblio’@’localhost’ (using password: YES)

    • #3050


      Jérôme
      Maître des clés

      Bonjour,

      L’erreur identique que les identifiants que vous avez saisis pour le compte root ne sont pas corrects.
      A vous de savoir quels identifiants vous devez taper ici. ça dépend de la configuration de votre système de gestion de base de données. On utilise généralement le compte root, mais ça peut être tout autre utilisateur disposant des droits nécessaires à la création d’une base de données et d’un utilisateur.

      Si l’installation ne va pas jusqu’au bout (c’est votre cas), le dossier var ne se créé pas.
      Il sera à la racine du dossier Planning Biblio.

      Cordialement,
      Jérôme

    • #3052


      foucaud
      Invité

      Bonjour.
      Merci de la réponse.
      J’ai finis par utiliser root pour lancer l’install, fermant les yeux sur le message « Do not run Composer as root/super user! ». L’installation est allé au bout.

      Tout n’est pas réglé, le serveur n’autorise pas encore l’accès (403 : ‘You don’t have permission to access this resource.’) mais il y a une avancée.

      Je ne sais pas encore ce qui dysfonctionne, j’ai ajouté /public dans la config apache

      # Ansible managed

      <VirtualHost *:80>

      ServerName planning-biblio-test.univ-pau.fr
      ServerAlias planning-biblio-test

      LogLevel info
      LogFormat « %h %l %u %t \ »%r\ » %>s %b \ »%{Referer}i\ » \ »%{User-agent}i\ » » combined
      CustomLog « |/usr/bin/logger -t httpd -p local7.info » combined
      ErrorLog « |/usr/bin/logger -t httpd -p local7.error »

      ServerAdmin name@site.fr

      DocumentRoot « /var/www/planning-biblio/public/ »
      <Directory « /var/www/planning-biblio/public »>
      Options -Indexes -FollowSymLinks -MultiViews
      AllowOverride All
      Require all granted
      </Directory>

      BrowserMatch « MSIE [2-6] » \
      nokeepalive ssl-unclean-shutdown \
      downgrade-1.0 force-response-1.0
      # MSIE 7 and newer should be able to use keepalive
      BrowserMatch « MSIE [7-9] » ssl-unclean-shutdown

      </VirtualHost>

      syslog :
      Apr 28 20:42:01 planning-biblio-test httpd[1553]: [Wed Apr 28 20:42:01.882965 2021] [rewrite:error] [pid 1555] [client 10.10.15.170:35828] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : /var/www/planning-biblio/public/
      Apr 28 20:42:01 planning-biblio-test httpd[1554]: 10.10.15.170 – – [28/Apr/2021:20:42:01 +0200] « GET / HTTP/1.1 » 403 513 « – » « Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:88.0) Gecko/20100101 Firefox/88.0 »

      Merci de votre aide.

Vous lisez 2 fils de discussion

Répondre à : Access denied for user ‘root’@’localhost’

Vos informations :